This project has moved and is read-only. For the latest updates, please go here.

Fixed MANY Task problems, but still have 5 critical ones that will not respond

Sep 9, 2015 at 12:34 AM
Hi Dijji,
Thanks for resolving many of the problems I had after reverting to Win 7 Pro from 10.
Yes, I should have waited longer to go to 10 and there are things to like but everyday was a new 'malfunction'. (10 Upgrade 2 wks ago, reversion to 7 Pro 64 4 days ago) but I thought I had everything backed up to redundant perfection. Acronis just will not revert back to original Win 7 64, so I used the control panel option and was left with a hobbled mess. I had at least 40 corrupted tasks and I AM Thankful that Repair Tasks DID fix the majority...many things much better but still have operational issues with what is otherwise a very high performance machine.

Would love some input from you or anyone with resulting 5 problems listed below that Repair Tasks just won't fix in admin mode.

Task image corrupt: Microsoft\Windows\PerfTrack\BackgroundConfigSurveyor
Task image corrupt: Microsoft\Windows\RAC\RacTask
Task image corrupt: Microsoft\Windows\Shell\WindowsParentalControls
Task image corrupt: Microsoft\Windows\Tcpip\IpAddressConflict1
Task image corrupt: Microsoft\Windows\Tcpip\IpAddressConflict2
Scan completed: 5 problems found

Sep 9, 2015 at 7:53 AM
Hi ChaacMesh

I’m betting that Repair is producing things like:

'ERROR: The task XML contains a value which is incorrectly formatted or out of range.(2,8):version:1.5’

If so, the steps to repair the remaining tasks are described towards the bottom of the Documentation page (see step 4 and later), and I really need to find a way of making this information more findable.

Sep 10, 2015 at 3:40 PM
Hi Dijji,
OK...I did finally see the zip with your supplied tasks...worked like a charm to fix those 5 above. Apparently I had more serious issues and while your fix did improve my situation, it could not restore my custom machine to it's previous state of near-perfection. Windows 10 is seemingly a plot.

Wanted to make sure you got my Most Sincere Thanks since when I did successfully revert to 7 64 pro from Acronis Disk Image from 8/7 last night I lost a few sent emails and not sure if they were sent, __

The other folks with the same problem need to know that your Supplied Tasks which work like a charm need to be in Documents or they cannot be 'chosen' if on desktop or other locale such as's that email....

Hi Dijji,
Sending this again just in case…reverted back to Disc Image from August 8 with Acronis…Success.
Had to reinstall a few updated programs that I installed after image backup, but no problems now…

Just wanted to thank you again & say you’ve got a great ‘touch’ with programming.
My friend and local ‘computer guru’ here who is an onsite repair guy for a local firm came over last night and was Very Impressed with your Task Repair…needless to say he absconded with it.

Thanks again for a very elegant solution to a real head-scratching problem!
Sep 10, 2015 at 3:46 PM
Edited Sep 10, 2015 at 3:53 PM
Dijji, Just FYI Data Miner updates:
Here's some great info on Win 7 updates by Fox Van Allen (techlicious) that are 'data miners' rid of them last night but it will take 'constant vigilance' to keep them from popping back up...Van Allen writes:

"Specifically, Microsoft has pushed four data-hungry updates: KB3068708, KB3022345 (which was replaced by the aforementioned KB3068708), KB3075249 and KB3080149. These updates say they are “for customer experience and diagnostic telemetry, and if installed, will regularly transmit data back to Microsoft. For some, this is a privacy concern; for others with metered Internet connections, Microsoft’s hunger for data could increase your monthly bill.

If you’re intentionally holding on to the Windows 7 or Windows 8 operating system despite Windows 10 being a free upgrade, you may want to avoid installing these four updates on your PC. If you’ve already installed them (the most likely scenario – Windows updates itself automatically unless you tell it not to), you might want to uninstall them. This is relatively easy to do: Enter the Control Panel > Programs > Programs and Features > Installed Updates. Right click an update listed in the paragraph above, and then choose “Uninstall.” Then repeat the process until all four updates have been removed from your machine.

Now, it’s important to note that even if you uninstall these updates, Windows will likely attempt to reinstall them during a later Windows Update unless you take action to block them too. To do so, press the Windows key on your computer keyboard and type “Windows Update.” Choose the Windows Update option that then pops up. Locate one of the four updates, right click it and select “Hide update.” Again, repeat the process for each.

If your computer is running Windows 10, there are a handful of privacy and sharing settings we recommend you change. Check out our guide to Windows 10 privacy settings that lists the operating system’s most egregious features, and spells out what you need to do to disable each. It’s a must-read for anyone with a PC".

[Broken shield via Shutterstock]

You probably are aware of this, but thought others might benefit,
Sep 10, 2015 at 5:07 PM
Here is a link to the article mentioned by ChaacMesh.

Here is the description provided by Microsoft for each of the updates that the article mentions:

KB3080149 This package updates the Diagnostics and Telemetry tracking service to existing devices. This service provides benefits from the latest version of Windows to systems that have not yet upgraded. The update also supports applications that are subscribed to Visual Studio Application Insights.

KB3068708 [was KB3022345] This update introduces the Diagnostics and Telemetry tracking service to existing devices. By applying this service, you can add benefits from the latest version of Windows to systems that have not yet upgraded. The update also supports applications that are subscribed to Visual Studio Application Insights.

KB3075249 This update adds telemetry points to the User Account Control (UAC) feature to collect information on elevations that come from low integrity levels.

Of the four, it looks like KB3080149 and KB3068708 are the ones to look seriously at. I do wonder: what telemetry was already being sent that this extends; how I can discover what is going on, so I can decide whether I care; and what settings, if any, affect what is or isn’t sent.

Nov 10, 2015 at 6:06 PM
Thank you so much for creating this tool! It corrected most of my corruptions except for one, but I still have to put up with having to click "Okay" on a bunch of error messages in the Task Scheduler (too many to reiterated here) every time I open it. Probably due to leftovers from Windows 10? How do we get rid of those? I tried everything I found that you recommended to do, including using the file method that you recommended, as well as searching for the fix from the backup copy of the tasks, and a copy of all of the tasks from another Windows 7 system and drive, but none of them corrected the errors. I also "unplugged" the one error found upon re-scan; and, when I open the Task Scheduler, I still have to click "Okay" on about a half dozen error messages (again, too many to quote here).

Can you please make this tool, or create another, that resolves all of those as well? Thanks again.
Nov 10, 2015 at 8:07 PM
Hi Steppen_Wolf

I will certainly try and help if I can. What errors are you seeing when you open Task Scheduler? I don’t need a complete list, but a sample would be very helpful. It sounds as though RepairTasks is now reporting no errors on a Scan, is that right?

Nov 10, 2015 at 9:57 PM
Edited Nov 12, 2015 at 1:55 AM
No, there is still one error, the "User_Feed_Synchronization..." one (although, as I said I "unplugged" that one, so hopefully it is not connected with the still-present errors). The other errors include... --Interruption-- Well, lo and behold, upon rebooting my computer and starting up the Task Scheduler after the reboot, all of the errors are gone now! I don't recall reading in any of your instructions that a reboot is required to fully realize the repairs (if I'm mistaken, I'm sorry). Also, forgive me, I don't mean to sound sarcastic, but don't you think it would be a very good idea to add that into the various places delineating and re-delineating your instructions?

Now what I'm wondering is, what about all of the "tasks" that are in sub-directories in the C:\Windows\System32\Tasks directory? For instance, the Apple ones to run the auto-notifier about Apple software updates. None of those "sub-directory" 'tasks' show up in the Task Scheduler; so, were they repaired and are they still running in the background though they don't show up in the Task Scheduler? Or were they NOT repaired, and were ignored by your tool? The latter certainly appears to be the case, but I hope I'm wrong. But if I'm right, is and/or are there some way(s) to recover them as well and/or make them show up in the Task Scheduler?

I have a bunch of such sub-directories in the Tasks directory, but NONE of their tasks show up in the Task Scheduler. Is that commonplace but they're still working? If so, I wasn't aware of that. Or, in the reversion to Win's 7 from Win's 10, were the .xml files in those sub-directories inadvertently deleted and thus not picked up by your repair tool? I tried looking for .xml files in any of those sub-directories, and the Tasks root directory, and I couldn't find ANY with the standard Windows File Manager, yet with the Folder Options setting(s) set to be able to see hidden files. Do .xml files not show up regardless, or is that something else screwed up by the reversion?

I am further wondering in general, not from you, if there are any other "mess-ups" of Windows caused by the reversion that most of us, as yet at least, don't know anything about. I have been getting a lot of BSOD crashes since the reversion a week or two ago, but Windows 7 was always an unstable OS, as was Windows 8.x and 10 even worse (I can't stand either of the latter), so I can't be sure if it's caused by the reversion or not, or by some other cause(s). I'll bet, even though Win's 10 and the reversion were supposed to preserve the Registry and fully restore it, that the Registry has been (severely?) messed up by the reversion.

Therefore, politely, what gives; or, what's going on with those other, "subdirectory", "tasks"? Thank you for your quite-timely response and for all of your attempts, and realizations of actually doing so, to help with this and/or these matters. You're a prince among men (or princess among women?). Cheers, my friend!
Nov 10, 2015 at 10:08 PM
Say, feel free to post your response(s) to my reiteration of this comment as a review, and add my response to it since I can't reply to your response(s) to reviews, if you like.

P.S.---I just ran your repair tool again just out of curiosity to see if that User_Feed_Synchronization error is still showing up, though unplugged, and it is; because I thought perhaps the reboot of my PC had corrected that one as well since the running of your repair tool (no such luck).
Nov 10, 2015 at 10:11 PM
...(A)nd I tried repairing it again, but it would still not repair.
Nov 11, 2015 at 4:33 PM
Hi Steppen_Wolf

I don’t recommend a reboot in the documentation because I’ve never encountered a situation in which one is required. The only time that a reboot has proved relevant before was when one correspondent had a machine where the Task Scheduler Service was not running, but that generated a long list of errors, including causing RepairTasks to report every task as being in an invalid state.

As for the question of the task files, what I would expect to see is that the Task Library in the left-hand pane of the Task Scheduler mirrors the folder structure in System32\Tasks, with each task file appearing as a task in the corresponding folder. What RepairTasks does when you Scan, is to walk the folders underneath System32\Tasks, checking that each task file that it encounters is installed as a task. If you are getting only one error, then the implication is that the tasks are indeed installed, and therefore I would expect them to appear in the Task Scheduler.

Finally, on the one remaining error, unplugging a task leaves its file under System32\Tasks, but removes it from the knowledge of the system. Therefore, an error will be produced every time you run Scan. RepairTasks will attempt to reinstall the task if you press Repair: I would be interested to know what error you are getting when you do this, especially if you’re using the zip file.

I hope this helps

Nov 12, 2015 at 1:48 AM
Edited Nov 12, 2015 at 12:43 PM
Well, my antivirus program just crashed Firefox as I was well into a response to you, and I don't have the heart to start the message all over again. What in God's name could cause Firefox to be shutdown in such a way is beyond me! It is absurd! It just suddenly, very quickly, with no warning, and no notice of a virus associated with Firefox, closed down completely, such that I had to restart it. Suffice it to say that, no, your reply did NOT help. You haven't answered ANY of my questions. I am highly physically disabled and do not have any energy to waste, nor can I afford to waste any, so please don't waste any of my very limited energy writing thorough, very carefully written, comments, and not responding to them thoroughly. I'm not writing those messages for my health you know.

The tasks from the sub-directories do NOT show up in the Task Scheduler, and you don't address that. Please read my longer post above very closely. And I already told you what that one error was/is.

In addition, as I said, I tend to think that the reversion somehow deleted the .xml files in the sub-directories, so your tool couldn't pick up on them and re-create those tasks. Are you alluding that you've never run into that, had that reported to you before, and/or haven't picked up on that yourself; or are you aware of it but are remaining quiet about it; because, obviously if those .xml files are no longer there, your tool can't "un-corrupt" them, unless of course it can "re- pull and create" them from the Registry or a backup copy from somewhere else in the system?

Further, contrary to your claim(s) that the latest version of your tool's file is a .zip file that can be read unopened, I tried to run your .zip files unopened and I got an error message (I don't remember now what it was) that it would not work that way because the file wasn't recognized as appropriate for the "Repair". So I unpacked your .zip files and used the unpacked folders to run "Repair" by your tool, which then ran successfully (but without restoring the tasks in the sub-directories. Thus, either your tool isn't finding the .xml files in the sub-directories because they are no longer there, or your tool isn't truly scanning "underneath" into those sub-directories and recovering those tasks as you believe it is.

Please give a thorough response to ALL of my posts, including both this one and the longer preceding one. Thank you much.
Nov 12, 2015 at 2:19 AM
I stand corrected (by myself), the Apple, Microsoft and other tasks show up on the Task Scheduler front page, "Task Scheduler (Local)" as active tasks; but they don't show up on the second page, the "Task Scheduler Library", and that's what threw me for a loop. I've never paid any attention to the first page of the Task Scheduler; because, as far as I know, the Task Scheduler Library page is the only page where you can edit the operation of the tasks, so it's the only page that I paid attention to; until now; because I have had occasions where I needed to edit and change some of the commands for the tasks, such as how often to run.
Nov 12, 2015 at 9:39 AM
You’re right, RepairTasks will not fix the User_Feed_Synchronization task. The Windows 7 tasks zip file does not include this task, as I took it from a fresh Windows 7 system, and the User_Feed_Synchronization task is not set up by default.

The task periodically synchronises RSS feeds with Internet Explorer. If you want this to work again, the best way forward would be to delete the task file (it is already unplugged from the Task Scheduler) and reconfigure IE, either from the command line, using:
msfeedssync enable
or I think from the Control Panel, at Control Panel > Internet Options > Content(tab) > Feeds and Web Slices > Settings(button)

Otherwise, you now seem to be in good shape. I have never come across reversion to Windows 7 removing task files. The only time I’ve seen task XML files disappear was with earlier versions of RepairTasks. The Repair operation involves temporary removal of the task file from System32\Tasks, and I had some problems where interference from antivirus programs prevented me from putting it back in cases where the repair failed. I fixed this in the end by renaming the files instead of moving them to the temp directory (see the source code for the full gory details).

Nov 12, 2015 at 1:08 PM
Edited Nov 12, 2015 at 1:38 PM
Yes, thank you, I do appear to be in good shape now. [Except, in fooling around with Andy's damn(ed) android emulator for the Windows desktop, I've been going through nothing but headaches, crashes and a waste of my time and energy! :o) Their product is replete with problems, but their "support", as is typical of "tech 'support'" today, is abysmal. Yesterday, as I was "swiping" with the mouse in the settings, I accidentally did something that turned the "home page" into a "dialer" page, and I couldn't get out of it and back to the actual home page with all of my many apps that I had installed. I wrote a message on Andy's so-called "support" page on Facebook; but, of course, they never responded with any help as usual. So, I had to reinstall the product; and, in the process, I of course lost all of the hours of work in installing, and all of those actual, apps. And, because Google is working with the NSA and the CIA (what I call, "al CIAduh{!}") in spying on all of us with huge computer systems, I didn't want them sharing my private information with the "gub'ment", so I had stupidly shut off all of my apps and settings being saved to their cloud, and allegedly deleted all of the info in the process (a deletion that they probably don't really do, but retain all of the info for "al CIAduh{!}" and the NSA), just before the problem (dummy me). I should have left the damn setting on until after I reinstalled Andy and restored all of the apps and settings; and, also of course, I didn't know when I shut that setting off that I was going to have that major problem and screw-up of Andy (but, of course, who knows, perhaps if I had left that setting on and restored from it, the restoration process would have put back that "setting" that caused the problem and the dialer page in the first place, and put me right back where I was stuck with that page and unable to get out it!). Thus, now, needless to say, I'm burned out screwing with Andy anymore, and I'm not going to "play" with it any longer and take the chance of re-installing all of those apps and something else going wrong and losing me all of my hard work.]

Thank you again for all of your help, and sorry for the misunderstanding.