This project has moved and is read-only. For the latest updates, please go here.

receiving Error code 0x81000031 when trying to create backup

Jan 27, 2016 at 10:03 AM
Hello Dijji

I thought to myself new year new OS as it kept popping up in the corner saying "here I am and Im free!" (Are we Beta bunnies?)

Like so many others I was having problems after down grading from windows 10, my main problem with 10 being graphics card issues with "nvlddmkm stop start TDR's" and black screens. The whole experience has taken a small chunk of my life trying to get my head around it.

Having thrown in the towel and reverting back to windows 7, like SO many others
Im finding myself with a different bunch of problems with the Task Scheduler "The task image is corrupt or has been tampered with" (0x80041321)" issue. Which after trawling
the internet has led me to your site and your dedecated efforts to devise a work around solutuion for something Microsoft should have nipped in the bud last year.

On finding I was not alone in my Woe's you web page has come as a relief on the road back to a stable Windows 7. I installed your program and it came up with some 130 errors.
After downloading your windows 7 tasks zip folder and clicking repair using the take task from backup it fixed a whole heap of stuff leaving me with just 11 tasks outstanding.
I read on your Documentation page
" There are also tasks added in more recent versions of Windows 10 that run code that does not exist at all in Windows 7, and therefore can be left unrepaired and unplugged,
or removed from the system by deleting the task files."
I went into the scheduler and followed the routes to the outstanding tasks and deleted what I thought were the related tasks.
I stopped to go back and check and now I have 13 issues and have a few like this
"Task Microsoft\Windows\AppID\EDP Policy Manager reported 'ERROR: The system cannot find the path specified."

I am happy that I have got this far but still have a little way to go as I still can't create a backup, im recieving Error code 0x81000031. Can you help? I can provide the aftermath text if it helps?

I like so many others here really apprieciate what you are doing and can not thank you enough. Some one did mention a donate button? Keep up the good work

Many thanks Stu
Jan 27, 2016 at 12:53 PM
Hi Stu

I think that my documentation has led you astray: I’ve updated it already. When you reached the point at which you had just the 11 Windows 10 tasks left, you were actually in good shape, and it should have been possible to set up backup. When my documentation said that you could ‘delete the task files’, it should have made it clear that it meant the files defining the tasks that are held under\System32\Tasks, because, at that point, the tasks are not registered with the Task Scheduler, and so could not have been deleted using it.

It follows that, when you deleted tasks using Task Scheduler, you must have been deleting healthy tasks with similar names instead. So now, the problem is to put them back. One helpful source might be the task files that you backed up, if you obey the prompts, when you started to use RepairTasks. If you let me know what the log from the Scan reports, and what errors you see when you start Task Scheduler, I can try and give you more specific advice.

Jan 27, 2016 at 5:03 PM
Hi Dijji

After growing weary a hole can be dug deeper right?

I ran the Task file back up which repaired two of the errors and got me back down to the 11.

In Task Scheduler I imported the tasks that I accidentally deleted from your Windows 7 zip and that repaired the 'ERROR: The system cannot find the path specified."

This is now the log from the Scan result

Task not installed: Microsoft\Windows\AppID\EDP Policy Manager
Task not installed: Microsoft\Windows\AppID\SmartScreenSpecific
Task not installed: Microsoft\Windows\CertificateServicesClient\AikCertEnrollTask
Task not installed: Microsoft\Windows\CertificateServicesClient\CryptoPolicyTask
Task not installed: Microsoft\Windows\CertificateServicesClient\KeyPreGenTask
Task not installed: Microsoft\Windows\Location\WindowsActionDialog
Task not installed: Microsoft\Windows\MemoryDiagnostic\RunFullMemoryDiagnostic
Task not installed: Microsoft\Windows\Shell\FamilySafetyMonitor
Task not installed: Microsoft\Windows\Shell\FamilySafetyRefresh
Task not installed: Microsoft\Windows\Shell\IndexerAutomaticMaintenance
Task not installed: Microsoft\Windows\Time Synchronization\ForceSynchronizeTime
Scan completed: 11 problems found

On Starting Task Scheduler I don't have any errors now.

On the Check Backup "pop up window" it details:

Windows Backup failed while determining libraries location of one of the users included in backup.
Details: The filename, directory name, or volume label syntax is incorrect.

Backup time;1/27/2016 4.39 pm
Backup Location: LaCie (I:)
Error code: 0x91000031

I had a look in the Scheduler and AutomaticBackup (last run succeeded 1/27/2016 4:19:59 PM) which is confusing me a little.

On another note: I recently deleted a partition and reformatted the LaCie hard-drive , not sure if that's relevant ?

Kind Regards

Jan 28, 2016 at 7:44 AM
Hi Stu

It looks like your tasks are in now in good shape, and can be left in their current state.

The backup problem is almost certainly unrelated. Best bet is a nasty little gotcha with libraries. If you go to the folders under Libraries, such as Pictures, right click and say Properties, it will display a list of Library Locations, which is the set of places conflated to form the library. A common cause of this problem is that a location has crept into one of these lists which is no longer accessible, such as the smartcard on a camera that was plugged in at some point, but no longer is. Check each of the library folders. Problem locations tend to have strange names, so it should be possible to spot the rogue, then you can just remove it from the list in the properties dialog.

Let me know if this does not work.

Jan 28, 2016 at 9:11 AM
Hello Dijji

Thank you for your swift reply

You where correct in that the location had a folder with a strange name! Im not sure if the link image is attached Image
I deleted it from the Libraries but alas It hasn't resolved the issue as yet.

Kind regards

Jan 28, 2016 at 2:10 PM
Edited Jan 28, 2016 at 2:15 PM
Hello Dijji

I cracked it

I went through this process:

a) Open Backup and Restore. Make sure to select “Change settings” in the backup and restore window.
b) Select the drive you wish to use for the backup.
c) Now, select “Let me choose” before clicking Next.
d) From the list, uncheck all the pre- selected libraries and uncheck “Include System Image”, switch off everything.
e) Switch on one library at time and started back up, if it backs up fine, cancel backup and go through process
(a to d) and added a library one at a time, repeating the process until it wouldn't back up.

I found that a folder which was linked to the video library used to have some films in was no longer there, so deleted the entry from the videos library.
It is now happily backing up and the problem appears to be solved, thank you once again for your help, problem solved.

Keep up the good work

And once again thank you