This project has moved and is read-only. For the latest updates, please go here.

Access denied errors

Nov 20, 2015 at 12:46 PM
Thank you for providing this tool. I downgraded because it turns out I have a Lenovo model that does not support upgrade to Windows 10 (Ideapad Y480) and didn't learn that until after I tried to upgrade.

I ran Task Repair once and it cleaned up a number of issues, but that didn't solve the backup problem, so I ran it again. Now it identifies 9 corrupt task images, then aborts with the message:

Scan terminated by unexpected error 'Access to the path 'ActivateWindowsSearch.hidden' is denied

If I go ahead and click the Repair button anyway, each of the 9 attempts to repair fails and results in a message of the form

Cannot copy task file 'C:\Windows\system32\Tasks\Adobe Flash Player Updater', Access to the path 'C:\Users\Richard\AppData\Local\Temp\Adobe Flash Player Updater' is denied

I'm running Repair Task from the downloads directory as administrator.

Any suggestions for how to resolve these problems? Thanks!
Nov 20, 2015 at 1:34 PM
Edited Nov 20, 2015 at 1:35 PM
Hi workman

Let me first explain a little about what is going on. When you run Repair, the task file has to be removed from System32\Tasks and reinstalled from another location. RepairTasks achieves this by copying the task file to the user’s temp folder, in your case ‘C:\Users\Richard\AppData\Local\Temp’, and renaming the existing task file X to X.hidden. If the repair fails, the task file is copied back to System32\Tasks. However, I have found that some antivirus products prevent or reverse this restore operation, so later Scan operations, on finding that a task file X.hidden is present but the corresponding task file X is not, rename X.hidden to X so that it does not just disappear from sight.

The obvious puzzle in your case is why did any repairs work? After all, they were performing exactly the same operations that are now failing.

I can’t immediately imagine an answer, but here are some things that you might try:
  • in Windows Explorer, navigate to Windows\System32\Tasks. If you get a message of the form “you do not have access to this folder, you want to grant it?”, say yes, then try things again.
  • temporarily turn off antivirus protection and run RepairTasks again
  • reboot the machine and try again. Sometimes a system can get into some strange states that only a reboot will cure.
Do let me know what you find

Nov 20, 2015 at 1:50 PM
Thanks for the reply, Dijji. So prompt!

Just after I posted this, I was reading the other threads and I found a recommendation to run Repair Tasks from the Documents directory. Sure enough, when I moved the app there, it ran like a charm and fixed all the corrupt images. I'm now relievedly finally doing a backup, after which I'll do a clean install and hopefully get the last Win10 detritus off the computer. I might add that problems with the Task Scheduler aren't the only ones I've had since the downgrade; I frequently can't install a new application, but get no error message. I'm now a Win10-phobe!
Nov 20, 2015 at 2:22 PM
Edited Nov 23, 2015 at 3:44 PM
Glad to hear that at least all your tasks are now back in shape.

I know that Windows marks files downloaded from the Internet as such; it looks like it runs them at a lower privilege level, too, whereas unzipping the executable to Documents will create a file without such a marking, and therefore with access to your full administrative privileges.

I have added a note to the documentation.